blob: 6ae0e7e6f3454180034cc34ad868ca3d2f468ef2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "7e3676a7fb14f65f568f12d4b40a2a72"
17SRC_URI[sha256sum] = "074db7c783a67b0667eca64a4f6a0c3de94998afc92c01d6453163eb04b9150d"
18
19S = "${WORKDIR}/Error-${PV}"
20
21inherit cpan
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
28BBCLASSEXTEND = "native"