blob: 533952cac79d2e709b19bb2de7f8357dbc54f00d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001From c99c61e8f863a508a0793168011c98dc74abbd05 Mon Sep 17 00:00:00 2001
2From: Dominic Hargreaves <dom@earth.li>
3Date: Sat, 14 Apr 2012 11:34:05 +0100
4Subject: Invoke x-terminal-emulator rather than xterm in perl5db.pl
5
6In Debian systems, xterm might not exist or might not be the preferred
7terminal emulator. Use x-terminal-emulator instead
8
9Bug-Debian: http://bugs.debian.org/668490
10Forwarded: not-needed
11
12Patch-Name: debian/perl5db-x-terminal-emulator.patch
13---
14 lib/perl5db.pl | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/lib/perl5db.pl b/lib/perl5db.pl
18index 7e7194e..c466bf3 100644
19--- a/lib/perl5db.pl
20+++ b/lib/perl5db.pl
21@@ -6960,7 +6960,7 @@ properly set up.
22 sub xterm_get_fork_TTY {
23 ( my $name = $0 ) =~ s,^.*[/\\],,s;
24 open XT,
25-qq[3>&1 xterm -title "Daughter Perl debugger $pids $name" -e sh -c 'tty 1>&3;\
26+qq[3>&1 x-terminal-emulator -T "Daughter Perl debugger $pids $name" -e sh -c 'tty 1>&3;\
27 sleep 10000000' |];
28
29 # Get the output from 'tty' and clean it up a little.