blob: 7dc45c68f21751dfdf35a517d34ba965e84ddd41 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Postinstall scriptlets"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5FILES_${PN}_append = " ${datadir}/postinst-intercepts/*"
6
7do_configure[noexec] = "1"
8do_compile[noexec] = "1"
9
10do_install() {
11 install -d ${D}${datadir}/postinst-intercepts
12 install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/
13 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/
14 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/
15 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/
16}
17
18inherit nativesdk
19INHIBIT_DEFAULT_DEPS = "1"