blob: 5008690ea43ed8a87e584faff31fcb55c8d8b5cb [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001LICENSE = "GPLv3+"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
8 file://run-ptest \
9"
10
11EXTRA_OECONF += "--without-libsigsegv-prefix"
12
13do_configure_prepend () {
14 # Need to remove gettext macros with weird mix of versions
15 for i in codeset.m4 gettext_gl.m4 intlmacosx.m4 inttypes-pri.m4 lib-ld_gl.m4 lib-prefix_gl.m4 po_gl.m4 ssize_t.m4 wchar_t.m4 wint_t.m4; do
16 rm -f ${S}/m4/$i
17 done
18}
19
20SRC_URI[md5sum] = "99180208ec2a82ce71f55b0d7389f1b3"
21SRC_URI[sha256sum] = "a25e89a8ab65fded1731e4186be1bb25cda967834b6df973599cdcd5abdfc19c"
22
23inherit ptest
24
25do_install_ptest() {
26 t=${D}${PTEST_PATH}
27 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
28 cp -r ${S}/tests $t/
29 install ${B}/tests/Makefile $t/tests/
30 sed -e 's|^Makefile:|_Makefile:|' \
31 -e 's|bash|sh|' \
32 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
33 -e 's|^srcdir = \(.*\)|srcdir = .|' \
34 -e 's|"`$(built_programs)`"|diff|' \
35 -e 's|gawk|awk|g' \
36 -i $t/tests/Makefile
37}