blob: 45d396639bec18067c5a6ca2d729903946be6061 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
2DESCRIPTION = "XML::SAX consists of several framework classes for using and \
3building Perl SAX2 XML parsers, filters, and drivers. It is designed \
4around the need to be able to "plug in" different SAX parsers to an \
5application without requiring programmer intervention. Those of you \
6familiar with the DBI will be right at home. Some of the designs \
7come from the Java JAXP specification (SAX part), only without the \
8javaness."
9
10SECTION = "libs"
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12DEPENDS += "libxml-namespacesupport-perl-native"
13RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
14PR = "r2"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "290f5375ae87fdebfdb5bc3854019f24"
21SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6f5ad84"
22
23S = "${WORKDIR}/XML-SAX-${PV}"
24
25inherit cpan
26
27BBCLASSEXTEND = "native"