blob: c0345178c4f3db561deaf22dc33e7f1136a21c72 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require ${BPN}.inc
2
3DEFAULT_PREFERENCE = "-1"
4
5SRCREV = "ea0d1f575c214c09ba3df12644a960e86e031766"
6PV = "10.5.4+git${SRCPV}"
7
8SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;branch=10.5"
9
10S = "${WORKDIR}/git"
11
12DEPENDS += "python-mako-native"
13
14inherit pythonnative
15
16#because we cannot rely on the fact that all apps will use pkgconfig,
17#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
18do_install_append() {
19 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
20 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
21 fi
22}