blob: 3537d8cbbad1a8af4bc47adc31834bae5b45e38c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2011 Intel Corporation
3#
4
5LICENSE = "MIT"
6PR = "r40"
7
8inherit packagegroup distro_features_check
9# rdepends on x11-common
10REQUIRED_DISTRO_FEATURES = "x11"
11
12PACKAGES = "${PN} ${PN}-utils"
13
14# xserver-common, x11-common
15VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
16
17# elsa, xserver-nodm-init
18VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
19
20SUMMARY = "X11 display server and basic utilities"
21RDEPENDS_${PN} = "\
22 ${PN}-xserver \
23 ${PN}-utils \
24 "
25
26SUMMARY_${PN}-utils = "X11 basic utilities and init"
27RDEPENDS_${PN}-utils = "\
28 ${VIRTUAL-RUNTIME_xserver_common} \
29 ${VIRTUAL-RUNTIME_graphical_init_manager} \
30 xauth \
31 xhost \
32 xset \
33 xrandr \
34 "