blob: bda82e7efc6a0d834cd225ce03f22a2e65aa1c58 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Liberation(tm) Fonts"
2DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
3created by Ascender(c) which aims at metric compatibility with \
4Arial, Times New Roman, Courier New."
5HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
6BUGTRACKER = "https://bugzilla.redhat.com/"
7
8RECIPE_NO_UPDATE_REASON = "2.x depends on fontforge package, which is not yet provided in oe-core"
9
10SECTION = "x11/fonts"
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
13PR = "r4"
14PE = "1"
15
16inherit allarch fontcache
17
18FONT_PACKAGES = "${PN}"
19
20SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \
21 file://30-liberation-aliases.conf"
22
23SRC_URI[md5sum] = "4846797ef0fc70b0cbaede2514677c58"
24SRC_URI[sha256sum] = "0e0d0957c85b758561a3d4aef4ebcd2c39959e5328429d96ae106249d83531a1"
25
26do_install () {
27 install -d ${D}${datadir}/fonts/ttf/
28 for i in *.ttf; do
29 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
30 done
31
32 install -d ${D}${sysconfdir}/fonts/conf.d/
33 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
34
35 install -d ${D}${prefix}/share/doc/${BPN}/
36 install -m 0644 License.txt ${D}${datadir}/doc/${BPN}/
37}
38
39PACKAGES = "${PN}"
40FILES_${PN} += "${sysconfdir} ${datadir}"