blob: 65348c376228cc14b573a6a95fae44829f5cb747 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Touchscreen calibration data from xinput-calibrator"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PR = "r7"
6
7SRC_URI = "file://pointercal.xinput"
8S = "${WORKDIR}"
9
10do_install() {
11 # Only install file if it has a contents
12 if [ -s ${S}/pointercal.xinput ] &&\
13 [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
14 install -d ${D}${sysconfdir}/
15 install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
16 fi
17}
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"