blob: 545874cdd4cdd67ee4ea433f2ee55ed27d6f90f1 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require xorg-lib-common.inc
2
3# libxpm requires xgettext to build
4inherit gettext
5
6SUMMARY = "Xpm: X Pixmap extension library"
7
8DESCRIPTION = "libXpm provides support and common operation for the XPM \
9pixmap format, which is commonly used in legacy X applications. XPM is \
10an extension of the monochrome XBM bitmap specificied in the X \
11protocol."
12
13LICENSE = "BSD"
14LIC_FILES_CHKSUM = "file://COPYING;md5=51f4270b012ecd4ab1a164f5f4ed6cf7"
15DEPENDS += "libxext libsm libxt"
16PE = "1"
17
18XORG_PN = "libXpm"
19
20PACKAGES =+ "sxpm cxpm"
21FILES_cxpm = "${bindir}/cxpm"
22FILES_sxpm = "${bindir}/sxpm"
23
24SRC_URI[md5sum] = "769ee12a43611cdebd38094eaf83f3f0"
25SRC_URI[sha256sum] = "c5bdafa51d1ae30086fac01ab83be8d47fe117b238d3437f8e965434090e041c"
26
27BBCLASSEXTEND = "native"