blob: e07c204c745bc09ed7775a995e6380e04014fae3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "X.Org X server configuration file"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/base"
4LICENSE = "MIT-X"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6PR = "r33"
7
8SRC_URI = "file://xorg.conf"
9
10SRC_URI_append_libc-musl = "\
11 file://10-preload-modules.conf \
12"
13
14S = "${WORKDIR}"
15
16CONFFILES_${PN} = "${sysconfdir}/X11/xorg.conf"
17CONFFILES_${PN}_append_libc-musl = " ${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf"
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20ALLOW_EMPTY_${PN} = "1"
21
22do_install () {
23 if test -s ${WORKDIR}/xorg.conf; then
24 install -d ${D}/${sysconfdir}/X11
25 install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
26 fi
27}
28
29do_install_append_libc-musl () {
30 install -Dm 0644 ${WORKDIR}/10-preload-modules.conf ${D}/${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf
31}