blob: c0615530af7272917ba737493fd05f08e2bbe762 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Provides a bridge between gconf and xsettings"
2HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4LICENSE = "MIT-style"
5LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
6 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
7DEPENDS = "gconf glib-2.0 gtk+"
8SECTION = "x11"
9SRCREV = "9a99528b02255450db81176abd9bbcc1dab9a4c1"
10PV = "0.0+git${SRCPV}"
11
12
13SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \
14 file://addsoundkeys.patch;apply=yes \
15 file://70settings-daemon.sh \
16 file://dso_linking_change_build_fix.patch"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig gconf distro_features_check
21
22FILES_${PN} = "${bindir}/* ${sysconfdir}"
23
24# Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES
25REQUIRED_DISTRO_FEATURES = "x11"
26
27do_install_append () {
28 install -d ${D}/${sysconfdir}/X11/Xsession.d
29 install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/
30}