blob: 13ba6773337cac3975dd8cba147ad6404d29b5fb [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Creates an 'xuser' account used for running X11"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
Patrick Williamsf1e5d692016-03-30 15:21:19 -05005SRC_URI = "file://system-xuser.conf"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
7inherit allarch useradd
8
9do_configure() {
10 :
11}
12
13do_compile() {
14 :
15}
16
17do_install() {
Patrick Williamsf1e5d692016-03-30 15:21:19 -050018 install -D -m 0644 ${WORKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019}
20
Patrick Williamsf1e5d692016-03-30 15:21:19 -050021FILES_${PN} = "${sysconfdir}/dbus-1/system.d/system-xuser.conf"
22
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023USERADD_PACKAGES = "${PN}"
24GROUPADD_PARAM_${PN} = "--system shutdown"
25USERADD_PARAM_${PN} = "--create-home \
26 --groups video,tty,audio,input,shutdown,disk \
27 --user-group xuser"
28
29ALLOW_EMPTY_${PN} = "1"