blob: 5fbf59443d940b3f15066e538c912b092247f2f4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# yocto-bsp-filename {{=example_recipe_name}}_0.1.bb
2#
3# This file was derived from the 'Hello World!' example recipe in the
4# Yocto Project Development Manual.
5#
6
7SUMMARY = "Simple helloworld application"
8SECTION = "examples"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
11
12SRC_URI = "file://helloworld.c"
13
14S = "${WORKDIR}"
15
16do_compile() {
17 ${CC} helloworld.c -o helloworld
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 helloworld ${D}${bindir}
23}