blob: bbfabf0209af389ae871f4a7c1f16d65e2c6e2a6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
7HOMEPAGE = "https://github.com/rhboot/grubby"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
11
12DEPENDS = "popt util-linux"
Patrick Williams213cb262021-08-07 19:21:33 -050013DEPENDS:append:libc-musl = " libexecinfo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15S = "${WORKDIR}/git"
16SRCREV = "a1d2ae93408c3408e672d7eba4550fdf27fb0201"
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https;;branch=master \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018 file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
19 file://run-ptest \
20 file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
21 file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
22 "
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += "dracut"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
26inherit autotools-brokensep ptest
27
Brad Bishop0f291cc2019-09-01 15:16:57 -040028EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}' 'PREFIX'=${@bb.utils.contains('DISTRO_FEATURES','usrmerge','/usr','',d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Patrick Williams213cb262021-08-07 19:21:33 -050030LIBS:libc-musl = "-lexecinfo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031LIBS ?= ""
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}
34 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
35 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038RDEPENDS:${PN} += "bash"
39RDEPENDS:${PN}-ptest = "util-linux-getopt bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040
Andrew Geissler595f6302022-01-24 19:11:47 +000041inherit update-alternatives
Andrew Geissler615f2f12022-07-15 14:00:58 -050042ALTERNATIVE:${PN} = "installkernel"
Andrew Geissler595f6302022-01-24 19:11:47 +000043ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
44
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'