blob: afdbdca4e3f078dbb3b0866469388fd02667d845 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Open client for Cisco AnyConnect VPN"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=8c2e1ec1540fb3e0beb68361344cba7e"
4
5SRC_URI = " \
6 git://git.infradead.org/users/dwmw2/openconnect.git;branch=master \
7"
Andrew Geissler615f2f12022-07-15 14:00:58 -05008SRCREV = "5695cd6b0c7d42ca293ce0f00abcbe3d1ec4e609"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009
10DEPENDS = "vpnc libxml2 krb5 gettext-native"
11RDEPENDS:${PN} = "bash python3-core vpnc-script"
12
13PACKAGECONFIG ??= "gnutls lz4 libproxy"
14
15# config defaults
16PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,"
17PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
18PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
19
20# not config defaults
21PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig bash-completion
26
27EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \
28 --disable-static"
29
30do_install:append() {
31 rm ${D}/usr/libexec/openconnect/hipreport-android.sh
32}