blob: 0b0bc29452940bd95a205fc6b0c350f30b0dc6c0 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# Copyright (C) 2020 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Kronosnet, often referred to as knet, is a network abstraction layer \
5 designed for High Availability use cases, where redundancy, security, \
6 fault tolerance and fast fail-over are the core requirements of your application."
7HOMEPAGE = "https://kronosnet.org/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-or-later & LGPL-2.1-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05009LIC_FILES_CHKSUM = "file://COPYING.applications;md5=751419260aa954499f7abaabaa882bbe \
10 file://COPYING.libraries;md5=2d5025d4aa3495befef8f17206a5b0a1"
11SECTION = "libs"
12DEPENDS = "doxygen-native libqb-native libxml2-native bzip2 libqb libxml2 libnl lksctp-tools lz4 lzo openssl nss xz zlib zstd"
13
14SRCREV = "0123ecebce0ad6aba3cdb320027192e15fd71e23"
15SRC_URI = "git://github.com/kronosnet/kronosnet;protocol=https;branch=stable1 \
16 file://0001-libknet-tests-Correct-include-path-for-poll.h.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050017 file://0001-links.c-Fix-build-with-gcc-12.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050018 "
19
20UPSTREAM_CHECK_URI = "https://github.com/kronosnet/kronosnet/releases"
21
22inherit autotools pkgconfig
23
24S = "${WORKDIR}/git"
25
26# libknet/transport_udp.c:326:48: error: comparison of integers of different signs: 'unsigned long' and 'int' [-Werror,-Wsign-compare]
27# for (cmsg = CMSG_FIRSTHDR(&msg);cmsg; cmsg = CMSG_NXTHDR(&msg, cmsg)) {
28# ^~~~~~~~~~~~~~~~~~~~~~~
29CFLAGS:append:toolchain-clang = " -Wno-sign-compare"
30
31PACKAGECONFIG[man] = "enable_man="yes", --disable-man, "
32
33PACKAGECONFIG:remove = "man"