blob: 05fa0c334cbf7b9629a62ddcc6d80af36635383e [file] [log] [blame]
Brad Bishop996bc452019-12-02 13:05:15 -05001require ${BPN}.inc
2
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SRC_URI += "file://${BPN}.initd \
4 file://0001-Remove-modules_clean-from-clean-target.patch \
5 "
Brad Bishop996bc452019-12-02 13:05:15 -05006
Patrick Williams213cb262021-08-07 19:21:33 -05007SRC_URI:append:libc-musl = " file://Drop-use-of-error-h.patch"
Brad Bishop996bc452019-12-02 13:05:15 -05008
9inherit update-rc.d
10
11INITSCRIPT_NAME = "${BPN}"
12
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14
Brad Bishop996bc452019-12-02 13:05:15 -050015do_compile() {
16 oe_runmake nbcat
17 oe_runmake mkemlog
18}
19
20do_install() {
21 install -Dm 0755 ${WORKDIR}/${BPN}.initd ${D}${sysconfdir}/init.d/${BPN}
22 install -Dm 0755 ${S}/nbcat ${D}${bindir}/nbcat
23 install -Dm 0755 ${S}/mkemlog ${D}${bindir}/mkemlog
24}
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RRECOMMENDS:${PN} += "kernel-module-emlog"
Andrew Geissler615f2f12022-07-15 14:00:58 -050027
28# The NVD database doesn't have a CPE for this product,
29# the name of this product is exactly the same as github.com/emlog/emlog
30# but it's not related in any way. The following CVEs are from that project
31# so they can be safely ignored
32CVE_CHECK_IGNORE += "\
33 CVE-2019-16868 \
34 CVE-2019-17073 \
35 CVE-2021-44584 \
36 CVE-2022-1526 \
37"