blob: 6afc45ab7e564430cb6363901235add23207a4d3 [file] [log] [blame]
Brad Bishop996bc452019-12-02 13:05:15 -05001SUMMARY = "LevelDB is a fast key-value storage library"
2DESCRIPTION = "LevelDB is a fast key-value storage library that provides an ordered mapping from string keys to string values"
3HOMEPAGE = "https://github.com/google/leveldb"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=92d1b128950b11ba8495b64938fc164d"
6
Andrew Geissler615f2f12022-07-15 14:00:58 -05007SRC_URI = "git://github.com/google/${BPN}.git;branch=main;protocol=https \
Brad Bishop996bc452019-12-02 13:05:15 -05008 file://run-ptest"
9
10SRCREV = "78b39d68c15ba020c0d60a3906fb66dbf1697595"
11S = "${WORKDIR}/git"
12
13inherit cmake ptest
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[benchmarks] = "-DLEVELDB_BUILD_BENCHMARKS=ON,-DLEVELDB_BUILD_BENCHMARKS=OFF,sqlite"
17PACKAGECONFIG[snappy] = ",,snappy"
18PACKAGECONFIG[tcmalloc] = ",,gperftools"
19
20EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=ON -DCMAKE_SKIP_RPATH=ON \
21 -DLEVELDB_BUILD_TESTS=${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'ON', 'OFF', d)}"
22
Patrick Williams213cb262021-08-07 19:21:33 -050023do_install:append() {
Brad Bishop996bc452019-12-02 13:05:15 -050024 install -D -m 0755 ${B}/leveldbutil ${D}${bindir}/leveldbutil
25}
26
27do_install_ptest() {
28 install -m 0755 ${B}/*_test ${D}${PTEST_PATH}
29}
30
31# Do not try to build lib32-leveldb for mips64, but allow libn32-leveldb.
32#
Patrick Williams213cb262021-08-07 19:21:33 -050033COMPATIBLE_HOST:mipsarcho32:pn-lib32-leveldb = "null"