blob: 2f92d810015a5e1e87d82b76087182c8160d326e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
2in many programming languages."
3AUTHOR = "Al Danial"
4
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE="GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
7
8SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz"
Andrew Geissler615f2f12022-07-15 14:00:58 -05009SRC_URI[sha256sum] = "08212290c4e9b21c7bb1abc0a9b4a365ce1c5eb0d8f3ebb74d50b29559a71a9c"
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"
12
13do_configure[noexec] = "1"
14do_compile[noexec] = "1"
15
16do_install() {
17 install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
18}
19
20RDEPENDS:${PN} = "perl perl-modules"