blob: 3ca47721006670896156267aad6d66463c7b1183 [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8DEPENDS = "flatbuffers-native"
9
10RDEPENDS:${PN}-compiler = "${PN}"
11RDEPENDS:${PN}-dev += "${PN}-compiler"
12
13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
14
15SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396"
16SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https"
17S = "${WORKDIR}/git"
18
19CVE_CHECK_IGNORE += "CVE-2020-35864"
20
21EXTRA_OECMAKE += " \
22 -DFLATBUFFERS_BUILD_TESTS=OFF \
23 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
24"
25EXTRA_OECMAKE:append:class-target = " -DFLATBUFFERS_FLATC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/flatc"
26
27inherit cmake python3native
28
29FILES:${PN}-compiler = "${bindir}"
30
31BBCLASSEXTEND = "native nativesdk"