blob: 0863bb862d7d3e85d00a38864593216630e2625d [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "A Perl module that checks whether a particular C library and its headers are available"
2DESCRIPTION = "This module provides a way of checking whether a particular library \
3and its headers are available, by attempting to compile a simple program and \
4link against it."
5HOMEPAGE = "https://metacpan.org/pod/Devel::CheckLib"
6SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishopc342db32019-05-15 21:57:59 -04008
9LIC_FILES_CHKSUM = "file://README;md5=7911cdbb572d25c5f2e2ea17f669efc2"
10
11SRC_URI = "https://cpan.metacpan.org/modules/by-module/Devel/Devel-CheckLib-${PV}.tar.gz \
12 file://0001-CheckLib.pm-don-t-execute-the-binary.patch \
13"
Brad Bishop8410d612019-11-25 09:40:59 -050014SRC_URI[md5sum] = "3519cbf9fe5ec3404449d5330ee5537f"
15SRC_URI[sha256sum] = "f21c5e299ad3ce0fdc0cb0f41378dca85a70e8d6c9a7599f0e56a957200ec294"
Brad Bishopc342db32019-05-15 21:57:59 -040016
17S = "${WORKDIR}/Devel-CheckLib-${PV}"
18
19inherit cpan
20
Andrew Geissler615f2f12022-07-15 14:00:58 -050021do_install:append() {
22 # update interpreter on shebang line
23 # since old version env doesn't support multiple arguments, replace option
24 # '-w' with 'use warnings;'
25 sed -i -e "s:^#!.*:#!/usr/bin/env perl:" \
26 -e "/use strict;/ause warnings;" ${D}${bindir}/use-devel-checklib
27}
28
Brad Bishopc342db32019-05-15 21:57:59 -040029BBCLASSEXTEND="native"