blob: be9704a3132d6b990391ca24e25630f9aabfdd86 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001SUMMARY = "Perl extension for generating and using LALR parsers"
2DESCRIPTION = "Parse::Yapp (Yet Another Perl Parser compiler) is a collection \
3of modules that let you generate and use yacc like thread safe (reentrant) parsers \
4with perl object oriented interface."
5
6HOMEPAGE = "http://search.cpan.org/dist/Parse-Yapp/"
7SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler69721092021-07-23 12:57:00 -04009
10LIC_FILES_CHKSUM = "file://lib/Parse/Yapp.pm;beginline=508;endline=521;md5=41a4542fcde97a600c9de0d782a90256"
11
12SRC_URI = "https://www.cpan.org/authors/id/W/WB/WBRASWELL/Parse-Yapp-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "69584d5b0f0304bb2a23cffcd982c5de"
15SRC_URI[sha256sum] = "3810e998308fba2e0f4f26043035032b027ce51ce5c8a52a8b8e340ca65f13e5"
16
17S = "${WORKDIR}/Parse-Yapp-${PV}"
18
19inherit cpan
20
Andrew Geissler615f2f12022-07-15 14:00:58 -050021do_install:append() {
22 sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/yapp
23}
24
Andrew Geissler69721092021-07-23 12:57:00 -040025BBCLASSEXTEND = "native"