blob: 111e948669e7b1bdc5f083de605d9762aa6a6ae0 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS:append:libc-musl = " argp-standalone"
10
11inherit autotools
12
Andrew Geissler615f2f12022-07-15 14:00:58 -050013SRCREV = "46d536709451609e5e99099216d9dcf567ceeaca"
Andrew Geissler595f6302022-01-24 19:11:47 +000014SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \
15 "
16S = "${WORKDIR}/git"
17
18LDFLAGS:append:libc-musl = " -largp"
19
20def set_target_arch(d):
21 import re
22 arch = d.getVar('TARGET_ARCH')
23 if re.match(r'i.86', arch, re.I):
24 return 'i386'
25 elif re.match('armeb', arch, re.I):
26 return 'arm'
27 else:
28 return arch
29
30EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
31 with_elfutils=/use/libelf/from/sysroot"
32
33do_configure() {
34 ${S}/configure ${EXTRA_UFTRACE_OECONF}
35}
36
37FILES_SOLIBSDEV = ""
38FILES:${PN} += "${libdir}/*.so"
39
40COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
41
42# uftrace supports armv6 and above
43COMPATIBLE_HOST:armv4 = 'null'
44COMPATIBLE_HOST:armv5 = 'null'