blob: 8cc7d74f9fa2a46ba777a3181122051cdd060e37 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-only | MIT"
Andrew Geissler615f2f12022-07-15 14:00:58 -050010LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
Andrew Geissler615f2f12022-07-15 14:00:58 -050012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
14SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
Andrew Geissler615f2f12022-07-15 14:00:58 -050015SRCREV = "dda4848a9911120a903bef6284fb88286f4464c9"
Andrew Geissler595f6302022-01-24 19:11:47 +000016
17S = "${WORKDIR}/git"
18
19DEPENDS:append:libc-musl = " libucontext"
20XCFLAGS = "-pthread"
21XCFLAGS:append:libc-musl = " -lucontext"
22
23EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
24do_configure() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000025 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000026}
27do_install () {
Andrew Geissler9aee5002022-03-30 16:27:02 +000028 oe_runmake install DESTDIR=${D}
Andrew Geissler595f6302022-01-24 19:11:47 +000029}