blob: aa8d138f2c4aaed2974130991cfd16a211db876c [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Crypt Openssl RSA cpan module"
2SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz \
Andrew Geisslereff27472021-10-29 15:35:00 -05007"
8
Andrew Geissler615f2f12022-07-15 14:00:58 -05009SRC_URI[sha256sum] = "bdbe630f6d6f540325746ad99977272ac8664ff81bd19f0adaba6d6f45efd864"
Andrew Geisslereff27472021-10-29 15:35:00 -050010
11DEPENDS += "libcrypt-openssl-guess-perl-native openssl"
12
13RDEPENDS:${PN} = " \
14 libcrypt-openssl-random-perl \
15 perl-module-autoloader \
16 perl-module-carp \
17 perl-module-strict \
18 perl-module-warnings \
19 perl-module-xsloader \
20"
21
22EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
23
24S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}"
25
26inherit cpan ptest-perl
27
28do_compile() {
29 export OTHERLDFLAGS='-Wl,-rpath'
30 cpan_do_compile
31}
32
33RDEPENDS:${PN}-ptest = " \
34 ${PN} \
35 perl-module-file-copy \
36 perl-module-test \
37 perl-module-test-more \
38"