blob: 868d70b4c819b57110507945424c97d8765f6374 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3AUTHOR = "Google Cloud Platform"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7inherit pypi setuptools3
8
Andrew Geissler615f2f12022-07-15 14:00:58 -05009SRC_URI[sha256sum] = "3b2f9d2f436cc7c3b363d0ac66470f42fede249c3bafcc504e9f0bcbe983cff0"
Andrew Geisslereff27472021-10-29 15:35:00 -050010
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19"
20
21RDEPENDS:${PN} += "\
22 ${PYTHON_PN}-aiohttp \
23 ${PYTHON_PN}-cachetools \
24 ${PYTHON_PN}-pyasn1-modules \
25 ${PYTHON_PN}-rsa \
26 ${PYTHON_PN}-six \
27"