blob: 90c8efeecae990779dd5e2727cde25cde93049bf [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
Andrew Geissler615f2f12022-07-15 14:00:58 -050013SRC_URI[sha256sum] = "f64b5378484be1d6ce59311f86174be29c8ff98d8d90f589e1c56d5acae67d3c"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
15RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
16
17BBCLASSEXTEND = "native nativesdk"