blob: 7ffec26e552df8793559b89dd6358b6983fc59a8 [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python."
2DESCRIPTION = " \
3Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \
4including RabbitMQ's extensions. \
5"
6SECTION = "devel/python"
7HOMEPAGE = "https://pika.readthedocs.io"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=678ec81495ba50edf81e84e4f1aa69f3"
10
11SRC_URI[sha256sum] = "15357ddc47a5c28f0b07d80e93d504cbbf7a1ad5e1cd129ecd27afe76472c529"
12
13inherit pypi python_setuptools_build_meta
14
15PYPI_PACKAGE = "pika"
16
17DEPENDS += " \
18 ${PYTHON_PN}-setuptools-scm-native \
19 ${PYTHON_PN}-toml-native \
20"
21
22RDEPENDS:${PN} += " \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-tornado \
25 ${PYTHON_PN}-twisted \
26"