blob: 433bfd60e849712e275076b6f1f87437854b9c26 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Seamless operability between C++11 and Python"
2HOMEPAGE = "https://github.com/wjakob/pybind11"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
5
6DEPENDS = "boost"
7
Andrew Geissler615f2f12022-07-15 14:00:58 -05008SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +00009 file://0001-Do-not-strip-binaries.patch \
10 file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
11"
Andrew Geissler615f2f12022-07-15 14:00:58 -050012SRCREV = "914c06fb252b6cc3727d0eedab6736e88a3fcb01"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
19
20inherit cmake setuptools3 python3native
21
Andrew Geissler9aee5002022-03-30 16:27:02 +000022PIP_INSTALL_DIST_PATH = "${S}/dist"
23PIP_INSTALL_PACKAGE = "pybind11"
24
Andrew Geissler595f6302022-01-24 19:11:47 +000025do_configure() {
26 cmake_do_configure
27}
28
29do_compile() {
30 setuptools3_do_compile
31 cmake_do_compile
32}
33
34do_install() {
35 setuptools3_do_install
36 cmake_do_install
37}
38
39BBCLASSEXTEND = "native nativesdk"