blob: 6085e48b3a7bcfc6629d8adff48db6740bbb6fcf [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dc4bb2668871655e24030dfe8d2a7ce7"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "b3d8e14d91cc95fb3dbc03a9d0588ac58326803eefa5bbb0978d109de3304fbe"
12
13RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj"
14
15export PROJ_INCDIR = "${STAGING_INCDIR}"
16export PROJ_LIBDIR = "${STAGING_LIBDIR}"