blob: daa290a54e760a88f58adcf2e12da8d88d70b41d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi ${PYTHON_PN}-pycparser"
6
Andrew Geissler615f2f12022-07-15 14:00:58 -05007SRC_URI[sha256sum] = "d400bfb9a37b1351253cb402671cea7e89bdecc294e8016a707f6d1d8ac934f9"
Andrew Geisslereff27472021-10-29 15:35:00 -05008
9inherit pypi setuptools3
10
11RDEPENDS:${PN}:class-target = " \
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pycparser \
15 ${PYTHON_PN}-shell \
16"
17
18BBCLASSEXTEND = "native nativesdk"