blob: f17f28a57fc2f6ac70d44a2cf72326f15455b45c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "An implementation of JSON Schema validation for Python"
2HOMEPAGE = "https://github.com/Julian/jsonschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
5 file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
6
Andrew Geissler615f2f12022-07-15 14:00:58 -05007SRC_URI[sha256sum] = "25203dbebd62a1179f810f14339f7a638baaf279b5cc3b738a58c3744af56d65"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Andrew Geissler615f2f12022-07-15 14:00:58 -05009inherit pypi python_hatchling
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
Andrew Geissler615f2f12022-07-15 14:00:58 -050011DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13PACKAGECONFIG ??= "format"
14PACKAGECONFIG[format] = ",,,\
15 ${PYTHON_PN}-idna \
16 ${PYTHON_PN}-jsonpointer \
17 ${PYTHON_PN}-webcolors \
18 ${PYTHON_PN}-rfc3987 \
19 ${PYTHON_PN}-strict-rfc3339 \
20"
21PACKAGECONFIG[nongpl] = ",,,\
22 ${PYTHON_PN}-idna \
23 ${PYTHON_PN}-jsonpointer \
24 ${PYTHON_PN}-webcolors \
25 ${PYTHON_PN}-rfc3986-validator \
26 ${PYTHON_PN}-rfc3339-validator \
27"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-attrs \
31 ${PYTHON_PN}-core \
32 ${PYTHON_PN}-datetime \
33 ${PYTHON_PN}-importlib-metadata \
34 ${PYTHON_PN}-io \
35 ${PYTHON_PN}-json \
36 ${PYTHON_PN}-netclient \
37 ${PYTHON_PN}-numbers \
38 ${PYTHON_PN}-pkgutil \
39 ${PYTHON_PN}-pprint \
40 ${PYTHON_PN}-pyrsistent \
41 ${PYTHON_PN}-shell \
42 ${PYTHON_PN}-six \
43 ${PYTHON_PN}-unittest \
44 ${PYTHON_PN}-setuptools-scm \
45 ${PYTHON_PN}-zipp \
46"
47
48BBCLASSEXTEND = "native nativesdk"