blob: 67cbd031002f21c8d4ba3eb09eaef7c78ee81c73 [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001HOMEPAGE = "http://tango.freedesktop.org/"
2SUMMARY = "Enables backwards compatibility with current desktop icon themes"
3DESCRIPTION = "A Perl script used for maintaining backwards \
4compatibility with current desktop icon themes, while migrating to the \
5names specified in the Icon Naming Specification. The Icon Naming \
6Utilities map the icon names used by the GNOME and KDE desktops to the \
7icon names proposed in the Icon Naming Specification, and generate the \
8icon files appropriate to the desktop environment you use. The Icon \
9Naming Specification provides a standard list of common icon contexts \
10and names that can be used to make icon themes work in a desktop \
11environment or application that implements the naming specification. "
12LICENSE = "GPL-2.0-only"
13DEPENDS = "libxml-simple-perl-native"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
16
17SRC_URI = "http://tango.freedesktop.org/releases/icon-naming-utils-${PV}.tar.gz"
18SRC_URI[sha256sum] = "044ab2199ed8c6a55ce36fd4fcd8b8021a5e21f5bab028c0a7cdcf52a5902e1c"
19
20inherit autotools allarch perlnative
21
22do_configure:append() {
23 # Make sure we use our nativeperl wrapper.
24 sed -i -e "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/icon-name-mapping.pl.in
25}
26
27FILES:${PN} += "${datadir}/dtds"
28
29BBCLASSEXTEND = "native"