blob: e2140bfdd70c021e08b4fca577929399b1d77312 [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Sato icon theme"
2HOMEPAGE = "https://www.yoctoproject.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "CC-BY-SA-3.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2"
7SECTION = "x11"
8
9DEPENDS = "icon-naming-utils-native libxml-simple-perl-native"
10
11SRC_URI = "git://git.yoctoproject.org/sato-icon-theme.git;protocol=https;branch=master"
12SRCREV = "d23f04ecb0328f655bf195df8eb04c1b734d53a9"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig allarch gtk-icon-cache perlnative
17
18# The configure script uses pkg-config to find native binaries to execute, so
19# tell it to use our pkg-config-native wrapper.
20export PKG_CONFIG = "pkg-config-native"
21
22FILES:${PN} += "${datadir}/icons/Sato"
23
24do_install:append() {
25 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \;
26 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \;
27 find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \;
28}