blob: b465f8817d2f4aea4f16f8c9b286efdac67f5e7c [file] [log] [blame]
Andrew Geissler635e0e42020-08-21 15:58:33 -05001SUMMARY = "Library for parsing command line options"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Popt is a C library for parsing command line parameters. Popt was heavily influenced by the getopt() and getopt_long() functions, but it improves on them by allowing more powerful argument expansion. Popt can parse arbitrary argv[] style arrays and automatically set variables based on command line arguments."
Andrew Geissler635e0e42020-08-21 15:58:33 -05003HOMEPAGE = "https://www.rpm.org/"
4SECTION = "libs"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
8
9DEPENDS = "virtual/libiconv"
10
Patrick Williamsde0582f2022-04-08 10:23:27 -050011SRC_URI = "\
12 http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
13 file://0001-popt-test-output-format-for-ptest.patch \
14 file://run-ptest \
15"
Andrew Geissler635e0e42020-08-21 15:58:33 -050016SRC_URI[sha256sum] = "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
17
Patrick Williamsde0582f2022-04-08 10:23:27 -050018inherit autotools gettext ptest
19
Andrew Geissler615f2f12022-07-15 14:00:58 -050020RDEPENDS:${PN}-ptest += "bash"
Patrick Williamsde0582f2022-04-08 10:23:27 -050021
22do_compile_ptest() {
23 sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
24}
25
26do_install_ptest() {
27 install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
28 install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
29 install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
30 install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
31}
Andrew Geissler635e0e42020-08-21 15:58:33 -050032
33BBCLASSEXTEND = "native nativesdk"