Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Setuptools Rust extension plugin" |
| 2 | DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \ |
| 3 | Python extensions implemented with PyO3 or rust-cpython.\ |
| 4 | \ |
| 5 | Compile and distribute Python extensions written in Rust as easily as if they were written in C." |
| 6 | HOMEPAGE = "https://github.com/PyO3/setuptools-rust" |
| 7 | BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5" |
| 11 | |
| 12 | SRC_URI = "${PYPI_SRC_URI} \ |
| 13 | https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \ |
| 14 | " |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "c86e734deac330597998bfbc08da45187e6b27837e23bd91eadb320732392262" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | |
| 17 | inherit cargo pypi python_setuptools_build_meta |
| 18 | |
| 19 | DEPENDS += "python3-setuptools-scm-native python3-wheel-native" |
| 20 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} += " \ |
| 22 | python3-distutils \ |
| 23 | python3-json \ |
| 24 | python3-semantic-version \ |
| 25 | python3-setuptools \ |
| 26 | python3-setuptools-scm \ |
| 27 | python3-shell \ |
| 28 | python3-toml \ |
| 29 | python3-typing-extensions \ |
| 30 | python3-wheel \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | BBCLASSEXTEND = "native" |