blob: f1da4b50e7d0ffad2249693a61c9aef9b8ef8a38 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Setuptools Rust extension plugin"
2DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
3Python extensions implemented with PyO3 or rust-cpython.\
4\
5Compile and distribute Python extensions written in Rust as easily as if they were written in C."
6HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
7BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
11
12SRC_URI = "${PYPI_SRC_URI} \
13 https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \
14 "
Patrick Williamsb542dec2023-06-09 01:26:37 -050015SRC_URI[sha256sum] = "c86e734deac330597998bfbc08da45187e6b27837e23bd91eadb320732392262"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17inherit cargo pypi python_setuptools_build_meta
18
19DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
20
Patrick Williamse760df82023-05-26 11:10:49 -050021RDEPENDS:${PN} += " \
22 python3-distutils \
23 python3-json \
24 python3-semantic-version \
25 python3-setuptools \
26 python3-setuptools-scm \
27 python3-shell \
28 python3-toml \
29 python3-typing-extensions \
30 python3-wheel \
Patrick Williams92b42cb2022-09-03 06:53:57 -050031"
32
33BBCLASSEXTEND = "native"