Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "A library implementing the 'SemVer' scheme." |
| 2 | DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)" |
| 3 | HOMEPAGE = "https://github.com/rbarrois/python-semanticversion" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2" |
| 6 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "bdabb6d336998cbb378d4b9db3a4b56a1e3235701dc05ea2690d9a997ed5041c" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "semantic_version" |
| 10 | inherit pypi setuptools3 |
| 11 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-pkg-resources \ |
| 14 | " |
| 15 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | BBCLASSEXTEND = "native nativesdk" |
| 17 | |
| 18 | UPSTREAM_CHECK_REGEX = "/semantic-version/(?P<pver>(\d+[\.\-_]*)+)/" |