blob: 4aacca49604ec29761126adc59e0d4b610066a25 [file] [log] [blame]
Brad Bishop36098402015-09-17 16:39:49 -04001# Common code for applications providing a D-Bus service.
2
3# Class users should define DBUS_SERVICES prior to including.
4
5python() {
Brad Bishop62ae0bf2015-09-21 17:07:52 -04006 services = d.getVar('DBUS_SERVICES', True)
7 if services:
8 uris = " ".join( [ 'file://' + s + '.conf' for s in services.split() ] )
9 d.appendVar('SRC_URI', uris)
Brad Bishop36098402015-09-17 16:39:49 -040010}
11
12do_install_append() {
13 # install the service configuration files
14 install -d ${D}${sysconfdir}/dbus-1/system.d
15 for s in ${DBUS_SERVICES}; do
16 install ${WORKDIR}/$s.conf ${D}${sysconfdir}/dbus-1/system.d/$s.conf
17 done
18}