blob: ec8f0de131632ff40e681ca3582fe739946eb495 [file] [log] [blame]
Yuan Yao72b8b7c2018-09-12 14:58:22 +08001SUMMARY = "HXT Rep board wiring"
2DESCRIPTION = "Board wiring information for the HXT Rep system."
3PR = "r1"
Patrick Venture31322722018-11-06 09:46:03 -08004LICENSE = "Apache-2.0"
Brad Bishopf5f8a282019-09-13 14:10:25 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Yuan Yao72b8b7c2018-09-12 14:58:22 +08006
7inherit allarch
8inherit setuptools
9inherit pythonnative
Yuan Yao72b8b7c2018-09-12 14:58:22 +080010
11PROVIDES += "virtual/obmc-inventory-data"
12RPROVIDES_${PN} += "virtual-obmc-inventory-data"
13
14DEPENDS += "python"
15
16S = "${WORKDIR}"
17SRC_URI += "file://Stardragon4800-rep2.py"
18
19python() {
20 machine = d.getVar('MACHINE', True).capitalize() + '.py'
21 d.setVar('_config_in_skeleton', machine)
22}
23
24do_make_setup() {
25 cp ${S}/${_config_in_skeleton} \
26 ${S}/obmc_system_config.py
27 cat <<EOF > ${S}/setup.py
28from distutils.core import setup
29
30setup(name='${BPN}',
31 version='${PR}',
32 py_modules=['obmc_system_config'],
33 )
34EOF
35}
36
37addtask make_setup after do_patch before do_configure
38