blob: fd004f4c9b3879373d9119da5daf3adb9dabd570 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
Andrew Geissler475cb722020-07-10 16:00:51 -05008
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009LICENSE = "GPLv3+"
Andrew Geissler475cb722020-07-10 16:00:51 -050010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12DEPENDS = "zlib"
13
Brad Bishopc342db32019-05-15 21:57:59 -040014SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
Andrew Geissler635e0e42020-08-21 15:58:33 -050015SRC_URI[sha256sum] = "34309a59d4b6b6b33756366aa9d3144a4655587be9f914476b4c0e2d36365f01"
Andrew Geissler475cb722020-07-10 16:00:51 -050016
Brad Bishop15ae2502019-06-18 21:44:24 -040017UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19inherit autotools
20
Brad Bishop19323692019-04-05 15:28:33 -040021# Remove ccache-native's dependencies, so that it can be used widely by
22# other native recipes.
23DEPENDS_class-native = ""
24EXTRA_OECONF_class-native = "--with-bundled-zlib"
25INHIBIT_AUTOTOOLS_DEPS_class-native = "1"
26PATCHTOOL = "patch"
27
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028BBCLASSEXTEND = "native"
Brad Bishop19323692019-04-05 15:28:33 -040029
30do_configure_class-native() {
31 oe_runconf
32}