blob: 4c2d4903157a114cdb8296abf0686298f3a92c3b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The LLVM Compiler Infrastructure"
5HOMEPAGE = "http://llvm.org"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04006LICENSE = "Apache-2.0-with-LLVM-exception"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007SECTION = "devel"
8
Brad Bishopf3f93bb2019-10-16 14:33:32 -04009LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
Brad Bishop08902b02019-08-20 09:16:51 -040011DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Andrew Geissler82c905d2020-04-13 13:39:40 -050013COMPATIBLE_HOST_riscv64 = "null"
14COMPATIBLE_HOST_riscv32 = "null"
15
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016RDEPENDS_${PN}_append_class-target = " ncurses-terminfo"
17
Brad Bishop19323692019-04-05 15:28:33 -040018inherit cmake pkgconfig
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PROVIDES += "llvm${PV}"
21
Andrew Geissler635e0e42020-08-21 15:58:33 -050022MAJOR_VERSION = "10"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040023MINOR_VERSION = "0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024PATCH_VERSION = "1"
Brad Bishopf3f93bb2019-10-16 14:33:32 -040025
26PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}"
27
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028LLVM_RELEASE = "${PV}"
29LLVM_DIR = "llvm${LLVM_RELEASE}"
30
Brad Bishop19323692019-04-05 15:28:33 -040031BRANCH = "release/${MAJOR_VERSION}.x"
Andrew Geissler635e0e42020-08-21 15:58:33 -050032SRCREV = "ef32c611aa214dea855364efd7ba451ec5ec3f74"
Brad Bishop19323692019-04-05 15:28:33 -040033SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
Brad Bishop08902b02019-08-20 09:16:51 -040034 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036 "
Brad Bishop19323692019-04-05 15:28:33 -040037
Andrew Geissler82c905d2020-04-13 13:39:40 -050038UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"
39
Brad Bishop19323692019-04-05 15:28:33 -040040S = "${WORKDIR}/git/llvm"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041
42LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
Brad Bishop19323692019-04-05 15:28:33 -040043
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044def get_llvm_arch(bb, d, arch_var):
45 import re
46 a = d.getVar(arch_var)
Brad Bishop19323692019-04-05 15:28:33 -040047 if re.match(r'(i.86|athlon|x86.64)$', a): return 'X86'
48 elif re.match(r'arm$', a): return 'ARM'
49 elif re.match(r'armeb$', a): return 'ARM'
50 elif re.match(r'aarch64$', a): return 'AArch64'
51 elif re.match(r'aarch64_be$', a): return 'AArch64'
52 elif re.match(r'mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips'
Brad Bishopf3f93bb2019-10-16 14:33:32 -040053 elif re.match(r'riscv(32|64)(eb|)$', a): return 'RISCV'
Brad Bishop19323692019-04-05 15:28:33 -040054 elif re.match(r'p(pc|owerpc)(|64)', a): return 'PowerPC'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055 else:
56 raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a)
57
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080058def get_llvm_host_arch(bb, d):
59 return get_llvm_arch(bb, d, 'HOST_ARCH')
60
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061#
62# Default to build all OE-Core supported target arches (user overridable).
63#
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080064LLVM_TARGETS ?= "AMDGPU;${@get_llvm_host_arch(bb, d)}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065
66ARM_INSTRUCTION_SET_armv5 = "arm"
67ARM_INSTRUCTION_SET_armv4t = "arm"
68
69EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
70 -DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \
71 -DLLVM_ENABLE_PIC=ON \
72 -DLLVM_BINDINGS_LIST='' \
73 -DLLVM_LINK_LLVM_DYLIB=ON \
74 -DLLVM_ENABLE_FFI=ON \
Brad Bishop19323692019-04-05 15:28:33 -040075 -DLLVM_ENABLE_RTTI=ON \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050076 -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
77 -DLLVM_OPTIMIZED_TABLEGEN=ON \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078 -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
Brad Bishop19323692019-04-05 15:28:33 -040079 -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
Brad Bishop79641f22019-09-10 07:20:22 -040080 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050081 -G Ninja"
82
83EXTRA_OECMAKE_append_class-target = "\
84 -DCMAKE_CROSSCOMPILING:BOOL=ON \
85 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080086 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050087 "
88
89EXTRA_OECMAKE_append_class-nativesdk = "\
90 -DCMAKE_CROSSCOMPILING:BOOL=ON \
91 -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080092 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050093 "
94
95do_configure_prepend() {
96# Fix paths in llvm-config
97 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp
98 sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp
99 sed -ri "s#lib/${LLVM_DIR}#${baselib}/${LLVM_DIR}#g" ${S}/tools/llvm-config/llvm-config.cpp
100}
101
102do_compile() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400103 ninja -v ${PARALLEL_MAKE}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500104}
105
106do_compile_class-native() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400107 ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500108}
109
110do_install() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400111 DESTDIR=${LLVM_INSTALL_DIR} ninja -v install
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500112 install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config
113
114 install -d ${D}${bindir}/${LLVM_DIR}
115 cp -r ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
116
117 install -d ${D}${includedir}/${LLVM_DIR}
118 cp -r ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
119
120 install -d ${D}${libdir}/${LLVM_DIR}
121
122 # The LLVM sources have "/lib" embedded and so we cannot completely rely on the ${libdir} variable
123 if [ -d ${LLVM_INSTALL_DIR}${libdir}/ ]; then
124 cp -r ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
125 elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib ]; then
126 cp -r ${LLVM_INSTALL_DIR}${prefix}/lib/* ${D}${libdir}/${LLVM_DIR}/
127 elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib64 ]; then
128 cp -r ${LLVM_INSTALL_DIR}${prefix}/lib64/* ${D}${libdir}/${LLVM_DIR}/
129 fi
130
131 # Remove unnecessary cmake files
132 rm -rf ${D}${libdir}/${LLVM_DIR}/cmake
133
Brad Bishop19323692019-04-05 15:28:33 -0400134 ln -s ${LLVM_DIR}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} ${D}${libdir}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV}
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500135
136 # We'll have to delete the libLLVM.so due to multiple reasons...
137 rm -rf ${D}${libdir}/${LLVM_DIR}/libLLVM.so
138 rm -rf ${D}${libdir}/${LLVM_DIR}/libLTO.so
139}
Brad Bishop19323692019-04-05 15:28:33 -0400140
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500141do_install_class-native() {
142 install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV}
143 install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV}
Brad Bishop19323692019-04-05 15:28:33 -0400144 install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500145}
146
Brad Bishop19323692019-04-05 15:28:33 -0400147PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500148
Brad Bishop19323692019-04-05 15:28:33 -0400149RRECOMMENDS_${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liboptremarks"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500150
151FILES_${PN}-bugpointpasses = "\
152 ${libdir}/${LLVM_DIR}/BugpointPasses.so \
153"
Brad Bishop19323692019-04-05 15:28:33 -0400154
155FILES_${PN}-libllvm = "\
156 ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.so \
157 ${libdir}/libLLVM-${MAJOR_VERSION}.so \
158"
159
160FILES_${PN}-liblto += "\
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500161 ${libdir}/${LLVM_DIR}/libLTO.so.* \
162"
163
Brad Bishop19323692019-04-05 15:28:33 -0400164FILES_${PN}-liboptremarks += "\
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400165 ${libdir}/${LLVM_DIR}/libRemarks.so.* \
Brad Bishop19323692019-04-05 15:28:33 -0400166"
167
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500168FILES_${PN}-llvmhello = "\
169 ${libdir}/${LLVM_DIR}/LLVMHello.so \
170"
171
Brad Bishop19323692019-04-05 15:28:33 -0400172FILES_${PN}-dev += " \
173 ${libdir}/${LLVM_DIR}/llvm-config \
Brad Bishopf3f93bb2019-10-16 14:33:32 -0400174 ${libdir}/${LLVM_DIR}/libRemarks.so \
Brad Bishop19323692019-04-05 15:28:33 -0400175 ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}.so \
176"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500177
Brad Bishop19323692019-04-05 15:28:33 -0400178FILES_${PN}-staticdev += "\
179 ${libdir}/${LLVM_DIR}/*.a \
180"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500181
Brad Bishop19323692019-04-05 15:28:33 -0400182INSANE_SKIP_${PN}-libllvm += "dev-so"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500183
184BBCLASSEXTEND = "native nativesdk"