blob: 3e1ba196b587be2d236b9dabf0147fcf48395c4d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "The Bitstream Vera fonts - TTF Edition"
2DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \
3faces (normal, oblique, bold, bold oblique) and two serif faces (normal \
4and bold). In addition Fontconfig/Xft2 can artificially oblique the \
5serif faces for you: this loses hinting and distorts the faces slightly, \
6but is visibly different than normal and bold, and reasonably pleasing."
7SECTION = "x11/fonts"
8LICENSE = "BitstreamVera"
9LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
10PR = "r7"
11
Andrew Geissler635e0e42020-08-21 15:58:33 -050012inherit allarch fontcache
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
14FONT_PACKAGES = "${PN}"
15
Brad Bishop316dfdd2018-06-25 12:45:53 -040016SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6"
18SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc"
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
20do_install () {
21 install -d ${D}${datadir}/fonts/ttf
22 for i in *.ttf; do
23 install -m 644 $i ${D}${datadir}/fonts/ttf
24 done
25
26 install -d ${D}${docdir}/${BPN}
27 for i in *.TXT; do
28 install -m 644 $i ${D}${docdir}/${BPN}
29 done
30}
31
32FILES_${PN} = "${datadir}/fonts"