Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "The Bitstream Vera fonts - TTF Edition" |
| 2 | DESCRIPTION = "The Bitstream Vera fonts include four monospace and sans \ |
| 3 | faces (normal, oblique, bold, bold oblique) and two serif faces (normal \ |
| 4 | and bold). In addition Fontconfig/Xft2 can artificially oblique the \ |
| 5 | serif faces for you: this loses hinting and distorts the faces slightly, \ |
| 6 | but is visibly different than normal and bold, and reasonably pleasing." |
| 7 | SECTION = "x11/fonts" |
| 8 | LICENSE = "BitstreamVera" |
| 9 | LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be" |
| 10 | PR = "r7" |
| 11 | |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame^] | 12 | inherit allarch fontcache |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | |
| 14 | FONT_PACKAGES = "${PN}" |
| 15 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | SRC_URI = "${GNOME_MIRROR}/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "bb22bd5b4675f5dbe17c6963d8c00ed6" |
| 18 | SRC_URI[sha256sum] = "db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | |
| 20 | do_install () { |
| 21 | install -d ${D}${datadir}/fonts/ttf |
| 22 | for i in *.ttf; do |
| 23 | install -m 644 $i ${D}${datadir}/fonts/ttf |
| 24 | done |
| 25 | |
| 26 | install -d ${D}${docdir}/${BPN} |
| 27 | for i in *.TXT; do |
| 28 | install -m 644 $i ${D}${docdir}/${BPN} |
| 29 | done |
| 30 | } |
| 31 | |
| 32 | FILES_${PN} = "${datadir}/fonts" |