blob: 52821195d1af985335b189b139924e6f807c8dd2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "VirGL virtual OpenGL renderer"
2DESCRIPTION = "Virgil is a research project to investigate the possibility of \
3creating a virtual 3D GPU for use inside qemu virtual machines, that allows \
4the guest operating system to use the capabilities of the host GPU to \
5accelerate 3D rendering."
6HOMEPAGE = "https://virgil3d.github.io/"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10"
10
Andrew Geissler635e0e42020-08-21 15:58:33 -050011DEPENDS = "libdrm virtual/libgl libepoxy"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012SRCREV = "7d204f3927be65fb3365dce01dbcd04d447a4985"
13SRC_URI = "git://anongit.freedesktop.org/virglrenderer \
14 file://0001-gallium-Expand-libc-check-to-be-platform-OS-check.patch \
15 file://0001-meson.build-use-python3-directly-for-python.patch \
16 "
17
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig features_check
21
22BBCLASSEXTEND = "native nativesdk"
23
24REQUIRED_DISTRO_FEATURES = "opengl"