blob: a9c7be0f819288c84f97dc49f2d950668c15acf9 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux kernel Development Source"
2DESCRIPTION = "Development source linux kernel. When built, this recipe packages the \
3source of the preferred virtual/kernel provider and makes it available for full kernel \
4development or external module builds"
5
6SECTION = "kernel"
7
8LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10inherit linux-kernel-base
11
12# Whilst not a module, this ensures we don't get multilib extended (which would make no sense)
13inherit module-base
14
15# We need the kernel to be staged (unpacked, patched and configured) before
16# we can grab the source and make the source package. We also need the bits from
17# ${B} not to change while we install, so virtual/kernel must finish do_compile.
18do_install[depends] += "virtual/kernel:do_shared_workdir"
19# Need the source, not just the output of populate_sysroot
20do_install[depends] += "virtual/kernel:do_install"
21
22# There's nothing to do here, except install the source where we can package it
23do_fetch[noexec] = "1"
24do_unpack[noexec] = "1"
25do_patch[noexec] = "1"
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028deltask do_populate_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030S = "${STAGING_KERNEL_DIR}"
31B = "${STAGING_KERNEL_BUILDDIR}"
32
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033PACKAGE_ARCH = "${MACHINE_ARCH}"
34
Brad Bishop19323692019-04-05 15:28:33 -040035KERNEL_BUILD_ROOT="${nonarch_base_libdir}/modules/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 kerneldir=${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}
39 install -d $kerneldir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 # create the directory structure
42 rm -f $kerneldir/build
43 rm -f $kerneldir/source
44 mkdir -p $kerneldir/build
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080046 # for compatibility with some older variants of this package, we
47 # create a /usr/src/kernel symlink to /lib/modules/<version>/source
48 mkdir -p ${D}/usr/src
49 (
50 cd ${D}/usr/src
Brad Bishop19323692019-04-05 15:28:33 -040051 lnr ${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}/source kernel
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 # for on target purposes, we unify build and source
55 (
56 cd $kerneldir
57 ln -s build source
58 )
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 # first copy everything
61 (
62 cd ${S}
63 cp --parents $(find -type f -name "Makefile*" -o -name "Kconfig*") $kerneldir/build
64 cp --parents $(find -type f -name "Build" -o -name "Build.include") $kerneldir/build
65 )
Brad Bishop316dfdd2018-06-25 12:45:53 -040066
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080067 # then drop all but the needed Makefiles/Kconfig files
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080068 rm -rf $kerneldir/build/scripts
69 rm -rf $kerneldir/build/include
70
71 # now copy in parts from the build that we'll need later
72 (
73 cd ${B}
74
75 cp Module.symvers $kerneldir/build
76 cp System.map* $kerneldir/build
77 if [ -s Module.markers ]; then
78 cp Module.markers $kerneldir/build
79 fi
80
Andrew Geissler82c905d2020-04-13 13:39:40 -050081 cp -a .config $kerneldir/build
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080082
83 # This scripts copy blow up QA, so for now, we require a more
84 # complex 'make scripts' to restore these, versus copying them
85 # here. Left as a reference to indicate that we know the scripts must
86 # be dealt with.
87 # cp -a scripts $kerneldir/build
88
89 if [ -d arch/${ARCH}/scripts ]; then
90 cp -a arch/${ARCH}/scripts $kerneldir/build/arch/${ARCH}
91 fi
92 if [ -f arch/${ARCH}/*lds ]; then
93 cp -a arch/${ARCH}/*lds $kerneldir/build/arch/${ARCH}
94 fi
95
96 rm -f $kerneldir/build/scripts/*.o
97 rm -f $kerneldir/build/scripts/*/*.o
98
99 if [ "${ARCH}" = "powerpc" ]; then
100 if [ -e arch/powerpc/lib/crtsavres.S ] ||
101 [ -e arch/powerpc/lib/crtsavres.o ]; then
102 cp -a --parents arch/powerpc/lib/crtsavres.[So] $kerneldir/build/
103 fi
104 fi
105
106 if [ "${ARCH}" = "arm64" ]; then
107 cp -a --parents arch/arm64/kernel/vdso/vdso.lds $kerneldir/build/
108 fi
109
110 cp -a include $kerneldir/build/include
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500111
112 # we don't usually copy generated files, since they can be rebuilt on the target,
113 # but without this file, we get a forced syncconfig run in v5.8+, which prompts and
114 # breaks workflows.
115 cp -a --parents include/generated/autoconf.h $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800116 )
117
118 # now grab the chunks from the source tree that we need
119 (
120 cd ${S}
121
122 cp -a scripts $kerneldir/build
123
124 # if our build dir had objtool, it will also be rebuilt on target, so
125 # we copy what is required for that build
126 if [ -f ${B}/tools/objtool/objtool ]; then
127 # these are a few files associated with objtool, since we'll need to
128 # rebuild it
129 cp -a --parents tools/build/Build.include $kerneldir/build/
130 cp -a --parents tools/build/Build $kerneldir/build/
131 cp -a --parents tools/build/fixdep.c $kerneldir/build/
132 cp -a --parents tools/scripts/utilities.mak $kerneldir/build/
133
134 # extra files, just in case
135 cp -a --parents tools/objtool/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500136 cp -a --parents tools/lib/* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800137 cp -a --parents tools/lib/subcmd/* $kerneldir/build/
138
139 cp -a --parents tools/include/* $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500140
141 cp -a --parents $(find tools/arch/${ARCH}/ -type f) $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800142 fi
143
144 if [ "${ARCH}" = "arm64" ]; then
145 # arch/arm64/include/asm/xen references arch/arm
146 cp -a --parents arch/arm/include/asm/xen $kerneldir/build/
147 # arch/arm64/include/asm/opcodes.h references arch/arm
148 cp -a --parents arch/arm/include/asm/opcodes.h $kerneldir/build/
149
Brad Bishop79641f22019-09-10 07:20:22 -0400150 cp -a --parents arch/arm64/kernel/vdso/*gettimeofday.* $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800151 cp -a --parents arch/arm64/kernel/vdso/sigreturn.S $kerneldir/build/
152 cp -a --parents arch/arm64/kernel/vdso/note.S $kerneldir/build/
153 cp -a --parents arch/arm64/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
154
Andrew Geissler82c905d2020-04-13 13:39:40 -0500155 cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800156 fi
157
Brad Bishop19323692019-04-05 15:28:33 -0400158 if [ "${ARCH}" = "powerpc" ]; then
159 # 5.0 needs these files, but don't error if they aren't present in the source
160 cp -a --parents arch/${ARCH}/kernel/syscalls/syscall.tbl $kerneldir/build/ 2>/dev/null || :
161 cp -a --parents arch/${ARCH}/kernel/syscalls/syscalltbl.sh $kerneldir/build/ 2>/dev/null || :
162 cp -a --parents arch/${ARCH}/kernel/syscalls/syscallhdr.sh $kerneldir/build/ 2>/dev/null || :
163 fi
164
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800165 # include the machine specific headers for ARM variants, if available.
166 if [ "${ARCH}" = "arm" ]; then
167 cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/
168
169 # include a few files for 'make prepare'
170 cp -a --parents arch/arm/tools/gen-mach-types $kerneldir/build/
171 cp -a --parents arch/arm/tools/mach-types $kerneldir/build/
Brad Bishop19323692019-04-05 15:28:33 -0400172
173 # ARM syscall table tools only exist for kernels v4.10 or later
174 SYSCALL_TOOLS=$(find arch/arm/tools -name "syscall*")
175 if [ -n "$SYSCALL_TOOLS" ] ; then
176 cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
177 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800178
179 cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
180 fi
181
182 if [ -d arch/${ARCH}/include ]; then
183 cp -a --parents arch/${ARCH}/include $kerneldir/build/
184 fi
185
186 cp -a include $kerneldir/build
187
Brad Bishop79641f22019-09-10 07:20:22 -0400188 cp -a --parents lib/vdso/* $kerneldir/build/ 2>/dev/null || :
189
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800190 cp -a --parents tools/include/tools/le_byteshift.h $kerneldir/build/
191 cp -a --parents tools/include/tools/be_byteshift.h $kerneldir/build/
192
193 # required for generate missing syscalls prepare phase
Andrew Geissler82c905d2020-04-13 13:39:40 -0500194 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
195 cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800196
197 if [ "${ARCH}" = "x86" ]; then
198 # files for 'make prepare' to succeed with kernel-devel
Andrew Geissler82c905d2020-04-13 13:39:40 -0500199 cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build/
200 cp -a --parents $(find arch/x86 -type f -name "syscalltbl.sh") $kerneldir/build/
201 cp -a --parents $(find arch/x86 -type f -name "syscallhdr.sh") $kerneldir/build/
202 cp -a --parents $(find arch/x86 -type f -name "syscall_64.tbl") $kerneldir/build/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800203 cp -a --parents arch/x86/tools/relocs_32.c $kerneldir/build/
204 cp -a --parents arch/x86/tools/relocs_64.c $kerneldir/build/
205 cp -a --parents arch/x86/tools/relocs.c $kerneldir/build/
206 cp -a --parents arch/x86/tools/relocs_common.c $kerneldir/build/
207 cp -a --parents arch/x86/tools/relocs.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500208 cp -a --parents arch/x86/tools/gen-insn-attr-x86.awk $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800209 cp -a --parents arch/x86/purgatory/purgatory.c $kerneldir/build/
210
211 # 4.18 + have unified the purgatory files, so we ignore any errors if
212 # these files are not present
213 cp -a --parents arch/x86/purgatory/sha256.h $kerneldir/build/ 2>/dev/null || :
214 cp -a --parents arch/x86/purgatory/sha256.c $kerneldir/build/ 2>/dev/null || :
215
216 cp -a --parents arch/x86/purgatory/stack.S $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400217 cp -a --parents arch/x86/purgatory/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800218 cp -a --parents arch/x86/purgatory/setup-x86_64.S $kerneldir/build/
219 cp -a --parents arch/x86/purgatory/entry64.S $kerneldir/build/
220 cp -a --parents arch/x86/boot/string.h $kerneldir/build/
221 cp -a --parents arch/x86/boot/string.c $kerneldir/build/
Brad Bishopc68388fc2019-08-26 01:33:31 -0400222 cp -a --parents arch/x86/boot/compressed/string.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800223 cp -a --parents arch/x86/boot/ctype.h $kerneldir/build/
Andrew Geissler82c905d2020-04-13 13:39:40 -0500224
225 # objtool requires these files
226 cp -a --parents arch/x86/lib/inat.c $kerneldir/build/ 2>/dev/null || :
227 cp -a --parents arch/x86/lib/insn.c $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800228 fi
229
230 if [ "${ARCH}" = "mips" ]; then
231 cp -a --parents arch/mips/Kbuild.platforms $kerneldir/build/
232 cp --parents $(find -type f -name "Platform") $kerneldir/build
233 cp --parents arch/mips/boot/tools/relocs* $kerneldir/build
234 cp -a --parents arch/mips/kernel/asm-offsets.c $kerneldir/build
235 cp -a --parents kernel/time/timeconst.bc $kerneldir/build
236 cp -a --parents kernel/bounds.c $kerneldir/build
237 cp -a --parents Kbuild $kerneldir/build
Brad Bishop19323692019-04-05 15:28:33 -0400238 cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build 2>/dev/null || :
239 cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build 2>/dev/null || :
240 cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800241 fi
242
243 # required to build scripts/selinux/genheaders/genheaders
244 cp -a --parents security/selinux/include/* $kerneldir/build/
Brad Bishopc342db32019-05-15 21:57:59 -0400245
246 # copy any localversion files
247 cp -a localversion* $kerneldir/build/ 2>/dev/null || :
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800248 )
249
250 # Make sure the Makefile and version.h have a matching timestamp so that
251 # external modules can be built
252 touch -r $kerneldir/build/Makefile $kerneldir/build/include/generated/uapi/linux/version.h
253
254 # Copy .config to include/config/auto.conf so "make prepare" is unnecessary.
255 cp $kerneldir/build/.config $kerneldir/build/include/config/auto.conf
256
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500257 # make sure these are at least as old as the .config, or rebuilds will trigger
258 touch -r $kerneldir/build/.config $kerneldir/build/include/generated/autoconf.h 2>/dev/null || :
259 touch -r $kerneldir/build/.config $kerneldir/build/include/config/auto.conf* 2>/dev/null || :
260
261 if [ -e "$kerneldir/build/include/config/auto.conf.cmd" ]; then
Andrew Geissler635e0e42020-08-21 15:58:33 -0500262 sed -i 's/ifneq "$(CC)" ".*-linux-.*gcc.*$/ifneq "$(CC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
263 sed -i 's/ifneq "$(LD)" ".*-linux-.*ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500264 sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
265 sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500266 # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig
267 sed -i 's/ifneq "$(KBUILD_DEFCONFIG)".*"\(.*\)"/ifneq "\1" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500268 fi
269
Brad Bishop79641f22019-09-10 07:20:22 -0400270 # make the scripts python3 safe. We won't be running these, and if they are
271 # left as /usr/bin/python rootfs assembly will fail, since we only have python3
272 # in the RDEPENDS (and the python3 package does not include /usr/bin/python)
273 for ss in $(find $kerneldir/build/scripts -type f -name '*'); do
274 sed -i 's,/usr/bin/python2,/usr/bin/env python3,' "$ss"
275 sed -i 's,/usr/bin/env python2,/usr/bin/env python3,' "$ss"
276 sed -i 's,/usr/bin/python,/usr/bin/env python3,' "$ss"
277 done
278
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800279 chown -R root:root ${D}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500280}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800281
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500282# Ensure we don't race against "make scripts" during cpio
283do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
284
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800285FILES_${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
286FILES_${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
287
Brad Bishop79641f22019-09-10 07:20:22 -0400288RDEPENDS_${PN} = "bc python3 flex bison ${TCLIBC}-utils"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800289# 4.15+ needs these next two RDEPENDS
290RDEPENDS_${PN} += "openssl-dev util-linux"
291# and x86 needs a bit more for 4.15+
292RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
Andrew Geissler635e0e42020-08-21 15:58:33 -0500293# 5.8+ needs gcc-plugins libmpc-dev
294RDEPENDS_${PN} += "gcc-plugins libmpc-dev"