blob: 9dfdb9e39b89a3f29eab608780ece57bb62fc6ed [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=492385fe22195952f5b9b197868ba268"
12
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
15 file://0001-Fixed-missed-ifndef-for-__mips_soft_float.patch \
16 file://0001-powerpc-fix-build-failure-on-power7-and-older-532.patch \
17 file://0001-Address-platforms-with-no-__int128.patch \
18 file://0001-Address-platforms-with-no-__int128-part2.patch \
19 file://0001-ffi_powerpc.h-fix-build-failure-with-powerpc7.patch \
20 "
21SRC_URI[md5sum] = "6313289e32f1d38a9df4770b014a2ca7"
22SRC_URI[sha256sum] = "72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056"
23UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
24UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
25
26EXTRA_OECONF += "--disable-builddir"
27EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
28inherit autotools texinfo multilib_header
29
30do_install_append() {
Andrew Geissler635e0e42020-08-21 15:58:33 -050031 oe_multilib_header ffi.h ffitarget.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050032}
33
34FILES_${PN}-dev += "${libdir}/libffi-${PV}"
35
36# Doesn't compile in MIPS16e mode due to use of hand-written
37# assembly
38MIPS_INSTRUCTION_SET = "mips"
39
40BBCLASSEXTEND = "native nativesdk"
41