blob: f1f252ce4f7635c76259ef07fef1fd023a937eee [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
Brad Bishop64c979e2019-11-04 13:55:29 -050017SRC_URI[md5sum] = "4660e25541071e933a2bb02ef2f94e7d"
18SRC_URI[sha256sum] = "7855b4b8f271ba6ee67d87d0965b975a9a8dbeaa616665ca2248afa3b5fcbc77"
Brad Bishopc342db32019-05-15 21:57:59 -040019
20do_configure_prepend () {
21 mkdir -p ${S}/build-aux
22}