blob: 5143d73ed76baa4c9d1d33a6a8cf08d8077d0795 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
Brad Bishop64c979e2019-11-04 13:55:29 -05006HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
Brad Bishop19323692019-04-05 15:28:33 -04008
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
15inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages
16
17SRC_URI += "file://run-ptest"
18SRC_URI[archive.md5sum] = "4d4bb9837f6d31e32d0ce658ae135f68"
19SRC_URI[archive.sha256sum] = "720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47"
20
21PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
22
Brad Bishop19323692019-04-05 15:28:33 -040023do_install_append() {
24 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
25 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
26 fi
27}
28
29BBCLASSEXTEND = "native nativesdk"
30
31# Currently it's not possible to disable gettext in Meson, so we need to force
32# this back on.
33USE_NLS_class-native = "yes"