blob: f7239d02294537f7dc0cc80c7eb559e17c2ac228 [file] [log] [blame]
Brad Bishop79641f22019-09-10 07:20:22 -04001KBRANCH ?= "v5.2/standard/tiny/base"
2KBRANCH_qemuarm ?= "v5.2/standard/tiny/arm-versatile-926ejs"
Brad Bishop19323692019-04-05 15:28:33 -04003
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
Brad Bishop64c979e2019-11-04 13:55:29 -05009LINUX_VERSION ?= "5.2.20"
Brad Bishop19323692019-04-05 15:28:33 -040010LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
Brad Bishop64c979e2019-11-04 13:55:29 -050018SRCREV_machine_qemuarm ?= "501d680535903acc00808c36f2cc07f2dc725adc"
19SRCREV_machine ?= "dd25a04fc5e2e4549fc9b86157a01e0c72b53b03"
20SRCREV_meta ?= "bd0762cd138f1624b5a5f8669cfa3ac2b71cb87b"
Brad Bishop19323692019-04-05 15:28:33 -040021
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
Brad Bishop79641f22019-09-10 07:20:22 -040025 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.2;destsuffix=${KMETA}"
Brad Bishop19323692019-04-05 15:28:33 -040026
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
Brad Bishopf3fd2882019-06-21 08:06:37 -040032KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"