Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Aspell spell-checker" |
| 2 | SECTION = "console/utils" |
| 3 | |
| 4 | LICENSE = "LGPLv2 | LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 6 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 7 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame^] | 8 | SRC_URI[md5sum] = "012fa9209203ae4e5a61c2a668fd10e3" |
| 9 | SRC_URI[sha256sum] = "f9b77e515334a751b2e60daab5db23499e26c9209f5e7b7443b05235ad0226f2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | PACKAGECONFIG ??= "" |
| 12 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" |
| 13 | |
| 14 | PACKAGES += "libaspell libpspell aspell-utils" |
| 15 | |
| 16 | RDEPENDS_${PN}-utils += "perl" |
| 17 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" |
| 19 | FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" |
| 20 | FILES_${PN} = "${bindir}/aspell" |
| 21 | FILES_libpspell = "${libdir}/libpspell.so.*" |
| 22 | FILES_${PN}-dev += "${bindir}/pspell-config" |
| 23 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 25 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 26 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 27 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | inherit autotools-brokensep gettext texinfo binconfig-disabled |
| 29 | |
| 30 | BINCONFIG = "${bindir}/pspell-config" |